Knowledge Base/iFit Overview/Announcements

Application Update 7" 10" Android-Touch Screen Machines - NEW UPDATE(2.2) - March 31 2014

Matt Evans
posted this on June 11, 2013 11:18 AM

Our most recent application update (March 21, 2014) will be released and will contain the following:

  • Add Follow workout button to video workouts

  • Prevent incline from moving when stop key is pressed to end the workout

  • StreetView Stability

  • Fixed login bug

  • Allow for non-case sensitive login.


The update should take 10 minutes to complete. The download times will vary based on download speeds, and the amount of units updating.

The update has been released for the following units:

  • NTL14011
  • NTL14010mp7
  • NTL20909
  • 24924
  • EPEL12912
  • NTL14212
  • SFTL15510
  • SFTL19511
  • SFEL51411
  • EPTL20912
  • NTEL91411
  • PFTL14011
  • EPEL16912
  • NTL19112

 


If the machines are left plugged in and connected to the internet over night the update will occur automatically. No additional steps will be required. You can verify that you have the most current app by pressing the, "Gear" icon on the homepage, then selecting, "Maintenance Mode." The current app version will be listed on the left side of that screen. The new application version is 2.2.

If you want to download the update immediately please follow the below steps or if the automatic update did not occur please see below;

Here are the steps for the update process with pictures:
1)From the home-screen, press the, "Gear" icon.
startpage.png
2) In the settings mode, select the, "Maintenance" Option:
hourglass.png
3) Then press, "Firmware Update" to begin the update process. 
4) Once the update has begun you should see a screen similar to this. Keep in mind, this can take about 10 minutes or more to finish.
asset_update.png

 

First Time User Set-up Slides

1 Intro-1.png

Press Begin Setup to start the set-up process!

2 connect-to-network.png

Press Connect to WIFI Network to connect your machine to WIFI to get the most out of your machine. Note: You will need to know your Network name(SSID) and passphrase(password). Hidden-Networks are not supported.

3 wifi-setup.png

Select your network from the list and enter in your password if needed(passwords are case-sensitive). Be sure that WIFI is ON, or you will not see any networks. Connect to your network then hit back to continue the setup. 

4 wifi-connected-change.png

You will see a green WIFI indicator that shows you are connected. You can change the network if you connected to the wrong one, or hit next to continue.

5 reigster.png

Enter your email address to register your equipment! Hit next when you have entered it in.

6a offers-maps.png

You will then see some of the offers that you can take advantage of as an owner of an iFit enabled machine! Be sure to hit YES to get the most out of your experience. 

Tutorials

7a walkthrough-dashboard.png

Be sure to review the tutorial slides to educate yourself on all the great features of your fitness equipment. When logging into iFit on your machine, a membership is required, and your username/password are case-sensitive.

7b walkthrough-workout.png

Great tips on how to use awesome features during a workout!

7c walkthrough-route.png

Be sure to try out drawing a route on your console! Google Map workouts are one of our best ways to experience iFit. 

By hitting Finish. you will be taken to the normal start screen of your machine where you can put all your new knowledge to use! 

 

Existing User-Slides

1_release-notes.png

Our Release notes for the update!

2d_offers-weight.png

Press Learn More to get more information on New iFit features!

3_email-dialog.png

Enter in your email address to get the latest information and news from iFit. 

 

Troubleshooting Tips:


The known issue with the update is related to WIFI, which will be specific to each unit, and network. You will need to verify that you have established a connection with your network prior to attempting to update the firmware. If you have any issues with the update, verify your connection by pressing the WIFI indicator in the bottom right corner, looking for the network to show it is connected, pressing the back arrow in the bottom right corner, and allow the machine to complete the update. We have had success in resolving the issue by power-cycling the unit, and trying again.

 

We are pleased to release the update that we have been working on, and testing for quite sometime now.  Our goal was to improve the overall function of the application, improve stability, and boost performance. All while fixing bugs that were affecting users. If you have any questions, comments, or concerns, please, submit a ticket. Good luck with your fitness goals!

 

Units with the Update Available

The update has been released for the following units:

  • NTL14011
  • NTL14010mp7
  • NTL20909
  • 24924
  • EPEL12912
  • NTL14212
  • SFTL15510
  • SFTL19511
  • SFEL51411
  • EPTL20912
  • NTEL91411
  • PFTL14011
  • EPEL16912
  • NTL19112
 

Comments

User photo
Mjctalt

These are great to hear, would still be nice to see, if a sleep mode could be also implemented in one of the fixes.  I have opened two tickets since purchasing our Elliptical, just get a simple response stating that the problem would be sent up to support for future review.  More like "neverland"

December 29, 2013 06:02 PM
User photo
Matt Evans
iFit

@MJCTALT: Thank you for your kind words. Could you please clarify what sort of sleep mode you are requesting? If you can give me more details, I can look into it, and get a feature request implemented. I think that would be a great feature, myself. 

December 30, 2013 03:52 PM
User photo
Matt Evans
iFit

Our latest version of the application does have a sleep screen implemented, but I am still not sure if we are thinking the same thing. 

 

December 30, 2013 03:53 PM
User photo
Rbgalvao2001
After the application update, my machine does not work, I received a message that I had a problem with the installation and after that I cannot log to ifit, my console does not log in. What I have to do now, it seems that I have to reset the console but I don't know how. I would apreciatte any help. My treadmill is a nordictrack x7i, but the problem happenned after the system was updated. Thank in advance for your help.
January 01, 2014 02:44 PM
User photo
Matt Evans
iFit

There may have been an issue with the update, but rest-assured we have a fix for that. Can you please refer to this article:https://ifit.zendesk.com/entries/22286660-StreetView-Fix-for-10-and...? Please update me when you are able to complete the process. 

January 02, 2014 09:24 AM
User photo
Rbgalvao2001
I followed the steps and my console is back. I believe everything is ok now. Thank you.
January 02, 2014 07:18 PM
User photo
Amanda Langan

I have had this update, and I have no problems other than I have no street view… I used to, but now its just a blank white screen…any help would be very much appreciated…. I have an Epic A35T

January 03, 2014 09:33 AM
User photo
Matt Evans
iFit

Amanda- Great to hear things are going better for you. No StreetView is a big problem, I would suggest that you follow the link that I commented above. It will fix your issue! Here it is again:https://ifit.zendesk.com/entries/22286660-StreetView-Fix-for-10-and.... Please let me know if you have any other questions, and how things go after the fix.

RBGAKVAO2001: Great to hear! I believe that everything should run great for you now. Please let me know if I can do anything else for you. 

January 03, 2014 09:58 AM
User photo
Amanda Langan

I found the fix….VERY happy….off to Venice I go ;-)…thanks for the help

January 03, 2014 10:15 AM
User photo
Misc

Have been trying to get a response from customer service with no luck. I'm stuck with 2.8.10. Please help with my ticket, 59440. It really stinks getting ignored for weeks.

January 04, 2014 05:46 PM
User photo
Asilva1

I just performed the update on my treadmill and got an error.  I went over to that article mentioned here and tried but can't get to the point to even perform those procedures.

January 05, 2014 10:14 AM
User photo
Matt Evans
iFit

@Misc: I believe that with that specific firmware version, you are on a different version of our Android consoles and this article does not apply. Are you experiencing any issues with your machine? 

@Asilva1: What error did you see? I would like you to fill out a ticket with our support team, or you can call us at 866-608-1798.

January 06, 2014 09:49 AM
User photo
Asilva1

The first error message I received was that the widget could not be loaded.  After that, it rebooted and would continue to look like it was rebooting (going from white screen with IFIT.COM to a gray screen).  I tried clicking on the items between "reboots" of the white screen and found that it allowed me to type.  I had to type one letter at each interval between white screens but eventually (after about 40 minutes) was able to complete those instructions and it appears to be okay now.

January 06, 2014 01:13 PM
User photo
Misc

Yes, the console will not connect to ifit live. Please see trouble ticket 59440. I paid $99 for year of ifit and it is useless without being able to connect to ifit. No response since 26December. Any help much appreciated. Just want the machine to work, it really takes away from my training and motivation dealing with this.

January 06, 2014 02:46 PM
User photo
Matt Evans
iFit

Misc: Your machine will display error 100 when the firmware is already up to date. Do you receive an error when you attempt to download a workout? Have you disconnected/forgot the WIFI connection, then connected, and tried again? I apologize that support has been slow. This is the busiest time of the year, but I can see why your ticket has been neglected for quite sometime. We strive for a less than 24 hour response time. 

January 06, 2014 02:51 PM
User photo
Misc

The internet works, I can use the browser and surf, the wifi is excellent in my house, and the treadmill is connected, confirmed from the android desktop. For the elite 9500, 2.8.10 is latest firmware? Tried connecting, disconnecting, different network (I work in an IT dept), power cycle. When trying to log into ifit, states "contacting ifit" and does nothing else

January 06, 2014 02:57 PM
User photo
Matt Evans
iFit

I think you have covered most of your bases. I need more specific information like the model number of your machine. With that I can set up a better test environment for your situation. Refer to the front page of your owners manual for where the model number is. 

January 06, 2014 02:59 PM
User photo
Misc

Ntl17010.3, 

January 06, 2014 03:01 PM
User photo
Matt Evans
iFit

@Misc: Can you give us a call at 866-608-1798? We have a reprogramming SD card that will help resolve your issues. Nordictrack, or iFit support can set up the order for you via your warranty.

January 06, 2014 03:29 PM
User photo
Misc

Tthanks Matt,

I called and they are going to get me the card. One last question just so I know. Is 2.8.10 the latest firmware for this elite pro 9500 purchased in 2011? 

January 06, 2014 03:39 PM
User photo
Robb Smithson

I am having the same problem as above, I've been on hold now for about 40 minutes (second call today with such a wait time), Is there a way to download the reprogramming to a usb or card?  My model is the NTL17010.1.

January 06, 2014 04:50 PM
User photo
Matt Evans
iFit

@Robb- Please either call, or submit a ticket with our support team. 

@Misc: Yes, I believe so. We designed the card to help reprogram the software when issues arise similar to yours. 

January 07, 2014 01:40 PM
User photo
Robb Smithson

@Matt - I have multiple times.  I need the card, it seems to me there should be a way to download it to a card so I don't have to wait for it to arrive.  I've been without my treadmill and IFIT since last November.  I think I have been pretty patient with you.

January 09, 2014 02:40 PM
User photo
Matt Evans
iFit

Robb: We don't have the software hosted publicly right now. I do show that your order has been processed and shipped yesterday. It shouldn't take long to receive the card. I appreciate your patience and am confident the card will resolve your issue. 

January 09, 2014 02:55 PM
User photo
Shelly N Jason

My treadmill and console worked perfect yesterday, I left the machine on all day and just went to use it and it is looping on the 'application assets update' it gets to 24 or 40 and states it can't find it and loops again.

How can I restore to factory settings or a date before this update automatically started ... because now my console program is 'hosed' .  I cannot get to anything (manual mode,informational mode, firmware update area, ect.).

January 09, 2014 06:55 PM
User photo
Shelly N Jason

Update to my about comment ... it is (24 / 42) ... not 40.

 

advpeb3k (24 / 42)

reading workout file

.... sits there for a few minutes 'reading' and then always states "Update failed" ... I tried the ifit clean up url link instructions above and same thing same error at the same location.  My wifi shows green just fine.

 

January 09, 2014 07:10 PM
User photo
marilu cineros

pues yo no puedo  instalar nada tengo todo el dia intentandolo y no puedooooooooooooooooooooooooo

January 09, 2014 09:32 PM
User photo
Shelly N Jason

It has been over a week since my ifit.com update ruined my ability to use my brandnew treadmill - have not recieved a call back from support and then closed my ticket stating it was resolved, yet no one did anything to resolve it.   I cannot use my treadmill at all as the software ruined the usage of my hardware machine.

January 17, 2014 01:18 PM
User photo
Jay Gleason

seams this fix though well intentioned may have, needed more test/debug... The previous work instruction worked well (sans the mention of the nonexistent "OK" button.... a good approach would to have make the fix automatic... or semiautomatic on request.... And to have made the corrected previous work instruction printable so it would easy to reference/implement by the customer:...  And to have some of the less experienced chimps that answer for tech support... do by: logging into customer computers/treadmils etc. and implement using macros

January 18, 2014 07:54 PM
User photo
Jay Gleason

that "Press OK" is still in step 8.... It should be "Press GO"!... pretty inexcusable... for a fix dated back to August! should have been repaired/corrected by Sept! 

January 18, 2014 08:07 PM
User photo
Matt Evans
iFit

@Jay: We are working on implementing the capability to proxy into machines during support, however, we do not currently have the ability to. I would love to resolve any issue with the instructions, but fail to see the above referenced error. What kind of issues are you experiencing?

January 20, 2014 10:05 AM
User photo
JINNY LUCAS

I can not get the HD video to work, it shows shows the lap screen, HELP!!  I just put it together last night.

 

January 22, 2014 07:21 PM
User photo
Neil Hawkes

Same as Jinny Lucas, I have also just built my Nordic Track T23 treadmill and updated as instructed to the latest firmware.  I cannot get the Halakalea or Hana HD Video options to produce any video, just the lap screen. Makes the 'Video' option a bit redundant now.

February 12, 2014 09:15 AM
User photo
Chris Park
@iFit: I have app version 2.1.38 my machine constantly adjusts elevation while running even though I'm just running in track mode flat course. After each run I need to recallibrate the incline in order to place treadmill into storage position
February 21, 2014 02:57 PM
User photo
Jade Spangenberg

I reactivated my iFit account a couple days ago.  I have used iFit in the past with my Nortigtrack Commercial 1750.  Every time I try to log in from my treadmill (which has worked fine in the past), I get invalid user/password.  When I try to do the firmware update, it just spins at Checking for Updates.  I'd really like to be able to use the service I'm paying for.  Please help!

App Version: 1.2.4.1143

Firmware Version: 3.0.0831.2

February 23, 2014 07:30 AM
User photo
Matt Evans
iFit

@Jinny and Neil- Could you look in the maintenance mode of your machine and advise me what your app version is? Also, could you provide me with your machines model number? 

@Chris: You have an update that has not been released yet and is currently being tested. You will need to refer to this article:https://ifit.zendesk.com/entries/22286660-StreetView-Fix-for-10-and.... To get back to 2.0. Also, please check in your maintenance mode and be sure that next to server, it doesn't say TEST.

@Jade: Could you please contact our support at 866-608-1798? We need to walk you through getting the latest version of the app, and your issues with be resolved. Thank you!

February 24, 2014 10:19 AM
User photo
Chris Park
@Matt Evan
It does say test next to server
February 24, 2014 10:29 AM
User photo
Neil Hawkes

Matt,  I contacted support who told me to reinstall the update from last year (2013) which reloads all the resources including the two missing video files. I did this and then updated to the latest firmware and the videos are now back (I had a strange situation with the Hana video said 125% downloaded?).

I have had the system crash on me about 2.5 miles into a run which was very annoying but it has not done this since. This was running using StreetView around MouseHole in the UK. I have filed a support query about this but have heard nothing back yet?

February 24, 2014 10:33 AM
User photo
Jade Spangenberg

Thanks for the response, Matt.  That is good to hear.

 

I opened a trouble ticket a couple days ago.  The status on the ticket is still, "THIS REQUEST IS AWAITING ASSIGNMENT TO A SUPPORT AGENT."

February 25, 2014 05:32 AM
User photo
Matt Evans
iFit

@Neil: You will want to follow these instructions:https://ifit.zendesk.com/entries/22286660-StreetView-Fix-for-10-and.... Let me know if you run into any problems. 

@Chris: Please go into the maintenance mode of your machine. When you are in the maintenance mode, Draw an hourglass in the bottom left of the screen over the words"App version, Firmware version, etc." By drawing that, you will see the machine change to say iFit Live, next to server. From there, everything should run beautifully. 

@Jade: I will see if we can have someone contact you asap. Our support agents are working hard to respond to ever ticket as soon as they can. 

February 25, 2014 10:53 AM
User photo
Neil Hawkes

Matt,  That's what I did, see comments above on the installation process with the 125% complete Hana video file download?   

Streetview etc works fine now and the video files are available. Only had 1 crash at 2.5 miles on a StreetView run, screen went Grey and had to power off and start again. Run information was lost which could be a bit annoying especially if the run had been longer.

Hasn't repeated on my NordicTrack T23 treadmill. Have latest firmware according to maintenance mode. If it happens again I will report all the version numbers you require although I agree with others that a software download I can put on a USB key as that is what is available on the treadmill not an SD card slot would be great. 

Looking forward to some updates on the site:

i. A search function

ii. Some more HD videos

iii. The ifit Score actually being the sum of the individual parts when you click on details, I've seen some strange maths going on.

 

Regards

Neil

February 26, 2014 01:38 AM
User photo
Matt Evans
iFit

@Neil: I agree on all 3 of your points and that is something we have planned and are working towards. I thank you for your detailed information and communication. If you do have any other issues going forward, please notify me. I would suggest to unplug the machine after each use to allow the machine to reboot before longer workouts. The manufacture of your machine recommends it, and if it were possibly a memory issue, the powercycle would help with that. Best of luck on your fitness goals! 

February 26, 2014 10:26 AM
User photo
Bernadette Cass

Hi all. I have a T23 and have tried all the usual stuff to login, with a lot of excellent help from Icon. but no luck as yet. 1.  I can't find the download with the link above. With all the info above I suspect the update has a 50% chance of solving the problem. Anyone have a different link? I just get the main website and have been unable to find downloads there. 2. I have all the updates my treadmill is willing to download. My app is 2.1.39 and I see from above I need something higher than 1.2.4.1229 or above. 3.  I was assured that this was a plug and play device when I bought it. I feel like I have paid a lot of money to be a guinea pig for the beta version.

February 27, 2014 12:08 PM
User photo
Matt Evans
iFit

@Bernadette: Please refer to this article: https://ifit.zendesk.com/entries/22286660-StreetView-Fix-for-10-and.... Your machine must have downloaded a pre-release version from our test server. You will need to switch that by going into the maintenance mode of your machine. Once there, draw an hourglass over the words app version, and firmware version. It should then say, "iFIt Live" next to server. 

February 27, 2014 12:38 PM
User photo
Bernadette Cass

Hi Matt. Thanks for the swift reply. I refered to the article in the link above. The photo below shows how far I got. I put in the HTTP://BIT.LY/IFITHELP in both lower case and capitals and got the same screen as in my attached photo. What shall I try next. Kindest regards  Bernadette

February 28, 2014 02:43 AM
User photo
Matt Evans
iFit

@Bernadette: Not a problem at all. I want to get things running smoothly for you. Could you try to erase the http:// and just enter in bit.ly/ifithelp? All lower-case and type it in the address bar, be sure not to enter it into Google. It is a direct link and if typed exactly like I listed above, will start the download. 

February 28, 2014 10:33 AM
User photo
Michelle Gaskey

I can't get mine to update past 2.8 - elite pro 9500 purchased in 2011.....same as many others above. Hasn't ever worked properly. I've tried calling multiple times but have yet to get through to someone bc of being on hold for ridiculous wait times. Does anyone ever actually get through to a real person...or is it just some cruel joke? What are the other options since calling and waiting doesn't actually amount to anything? My 3 year warranty will be up in May...have yet to be able to use it...and sincerely concerned that I won't get through to customer service before May. :-/

March 03, 2014 04:09 PM
User photo
Kevin Sullivan

HI Matt,

 

i got the street view working but now i have a new issue - the scheduled workouts queues dont load properly on the android 10 inch tablet on my commercial 2950 for some reason

it shows the correct program ie say level 4 but it shows workout 1 to 5  on the ifit website i have workout number GF lvl 4 #15 scheduled

 

the same thing is occurring for both the primary and the additional users

i have tried restarting (power off and on) the treadmill machine and resetting my internet connection (router)

is there an issue with the ifit server today??

March 05, 2014 06:50 PM
User photo
Bernadette Cass

Hi Matt. I am a week late in replying. My apologies. With the last fix I was straight in and have two additional users enjoying our T23. Could I suggest a online ifit instruction booklet, updated by you on a monthly basis. this could be available on the ICON wesite as well as the ifit website. Kindest regards Bernadette.

March 10, 2014 02:36 PM