iFIT Act Compatibility


The iFit All Day Fitness app that is used to upload and manage your iFit Act device has the following compatibility requirements.

  • For IOS, an iPhone 4S, 5S, 5C, and above are required. iPod Touch 5th generation and above.

  • Android 4.3 with Bluetooth 4.0 with BLE is required.

The iFit Act device uses Bluetooth low energy, also known as BLE.

Have more questions? Submit a request